Problems Playing HD Recordings - No Audio Track

Live TV, EPG, Recordings, Pay TV CAM, Remote Access and other issues
Post Reply
GeoffatMM
Posts: 2
Joined: Sun Jun 30, 2019 9:32 am

Problems Playing HD Recordings - No Audio Track

Post by GeoffatMM » Mon Aug 05, 2019 10:38 am

Hi All

I am recording TV programmes successfully on Kodi 18.3 Leia via my iMac and the VBox PVR add-on but am having issues with their playback. I have posted on the Kodi forum and am waiting a response.

While waiting to hear back I tried opening the recorded files in Quicktime and found that HD channel recordings were not working properly as there was no audio. Non HD channels were fine. Both are listed as .mpg files.

Using the Movie Inspector window in Quicktime, I can see that the HD channels are encoded using H.264. The non HD channels use MPEG Layer 2.

When I convert the HD files using Handbrake from .mpg to .mp4, Handbrake adds an AAC audio track alongside the H.264 (video?) output. This must mean that the audio channel is in the original file but the way it is set prevents quicktime from finding and using it?

So is the H.264 encoding for HD and the MPEG Layer 2 for non HD channels determined by the TV transmission or is this something that the VBox controls?

In either case, is it possible to tell Kodi to record HD channels (or all channels) in H.264 but with AAC audio? Or is there a simpler solution?

What codec does The VBox recording use and is there a compatible codec I can load to my quicktime folder that will enable the audio to be properly interpreted?

This is a real problem as I currently cannot watch recorded programmes without converting them through Handbrake which is a lengthy operation.

Thanks,

Geoff

Post Reply