Web livetv guide loading

Live TV, EPG, Recordings, Pay TV CAM, Remote Access and other issues
Post Reply
Ant
Posts: 79
Joined: Tue Jan 31, 2017 5:28 am

Web livetv guide loading

Post by Ant » Wed May 09, 2018 10:14 am

Hi.

Does anybody experienced problem sometimes?:

1. After full device setup and epg search done.
2. Open browser on your pc (firefox, chrome).
3. Open http://vbox_ip/livetv/
4. Click icon Guide
5. At that moment on screen part of interface, no epg data and icon in center of page LOADING DATA.

This problem is not often, for example tomorrow it loads fine.
And no problem if click live tv and check epg via info or left part of interface with channel names.
Also no problem with android pink app (legasy gray app is having this problem too afaik).

tarmacalastair
Posts: 95
Joined: Wed Mar 22, 2017 10:05 am

Re: Web livetv guide loading

Post by tarmacalastair » Wed May 09, 2018 5:46 pm

Yes, seen that happen lots, both on a PC browser (Firefox on Linux) and in the Android grey app. Like you though, I never seem to be able to predict when it will play up - seems to be fine at the moment.

I've given up in the grey app on my phone as it's so unreliable. The pink one seems to work more reliably on my phone, even though it is supposed to be for tablets only.

Ant
Posts: 79
Joined: Tue Jan 31, 2017 5:28 am

Re: Web livetv guide loading

Post by Ant » Thu May 10, 2018 4:54 am

What i already done:
Check that it's not speed related issue:
1. Switched port of vbox to 10M half. Open 6Mbit hd channel. Tries open guide. Works fine. (300KB/s)
2. Imitate more bad connection via 4g poor receipt. Tries open guide. Works fine. (12-15 KB/s)

Check epg itself:
3. When it's problem comes, i was able download xmltv from iptv part.
I put it in webserver in my lan, then change time on vbox and tell it download xmltv from lan. Tries open guide. Works fine.

Still have an idea that maybe it's size of epg and some of services in vbox.
Will try reduce time of epg when problem comes again and check.

dannyscarb
Posts: 18
Joined: Wed Mar 21, 2018 8:41 pm

Re: Web livetv guide loading

Post by dannyscarb » Thu May 10, 2018 6:41 am

I had a bit of trouble with my xmltv data when my EPG duration was set to 7 days. Changing it to 5 days sorted it for me.

Ant
Posts: 79
Joined: Tue Jan 31, 2017 5:28 am

Re: Web livetv guide loading

Post by Ant » Thu May 10, 2018 6:58 am

In my case epg data from my provider is just about 3-4 days.
Will wait for next repeat and try reduce it.

Maybe there is something difference between how web livetv page extract xml program and how it does android pink app and wget when doing:
http://vbox_ipip:55555/vboxXmltv.xml

Page livetv:
May 10 10:02:18 HttpControlApp: (941) [HTTP_CTL] [A] HTTP Control GetXmltvSection exited
Wget:
May 10 10:02:59 VboxUpnpMediaServer: (951) [UPNP_SRV] VboxMediaServerDelegate::ProcessFileRequest - vboxXmltv.xml
Pink Android App:
May 10 10:11:01 HttpControlApp: (270) [HTTP_CTL] [A] HTTP Control GetXmltvSection entered
May 10 10:11:38 HttpControlApp: (331) [HTTP_CTL] [A] HTTP Control GetXmltvSection exited

Looks like not, but anyway i see which service i suppose we can set to debug log.
But need ask support about it.

Post Reply