Recordings.xml issues

Live TV, EPG, Recordings, Pay TV CAM, Remote Access and other issues
Post Reply
dhallam
Posts: 13
Joined: Thu Feb 02, 2017 10:46 am

Recordings.xml issues

Post by dhallam » Thu Jul 19, 2018 6:52 pm

All my recorded TV is is mounted to my server at \\server\recorded tv
the share has full permissions and has been working fine until I rebuilt my server last week.

For about a day the share was unavailable while I recreated the share but now only a handful of recordings are showing now the share is back online.

Within the XML file the files that are not now showing up are all now like this:
<record channel="www.Channel%205.co.un" start="20161106170816 +0000" stop="20161106180500 +0000">
<channel-name>Channel 5</channel-name>
<programme-title lang="eng">2012</programme-title>
<programme-desc lang="eng">Action starring John Cusack and Amanda Peet. A divorced writer battles to save his family from a series of natural disasters caused by solar eruptions. (2009)[S]</programme-desc>
<record-id>52</record-id>
<state>Error</state>
<error-description>File does not exist</error-description>
<url>http://192.168.1.7:55555/NetworkMedia%2 ... 8.mpg</url>
</encodedDescription>

only included the needed section and im assuming is down to the <state> now being file does not exist.

But if I go to http://192.168.1.7:55555/NetworkMedia%2 ... 7%2D08.mpg
the file does download and I can see it.

Is their anyway to get this to re-check or anything I can amend to get the recordings back into the VBOX


the ones that do work look like this:

<channel-name>Sony Movie Ch</channel-name>
<programme-title lang="eng">Jumanji</programme-title>
<programme-desc lang="eng">An unusual board game unleashes unstoppable forces into the lives of a makeshift family. Robin Williams stars in this fantasy adventure. (1995)</programme-desc>
<record-id>248451</record-id>
<state>recorded</state>
<url>http://192.168.1.7:55555/NetworkMedia%2 ... 4.mpg</url>
<LocalTarget>/usr/local/bin/vboxUpnp/shared/NetworkMedia/Jumanji__Sony Movie Ch__26-01-2018_15-54.mpg</LocalTarget>
<encodedTitle>


and I have rebooted the device a few times.

currentaly running XTI_VJ.2.57.17
and its a 3442-21

cheers for any advice.

dhallam
Posts: 13
Joined: Thu Feb 02, 2017 10:46 am

Re: Recordings.xml issues

Post by dhallam » Thu Jul 19, 2018 7:22 pm

too quick to ask, I resolved it by doing a find and replace on the recordings.xml file for <state>Error</state> to <state>recorded</state>

and deleted any <error-description>File does not exist</error-description>

all back on now... and jest I did have a backup of recordings.xml

might help anyone else... but might not :-)

Linux_lad
Posts: 5
Joined: Wed Dec 20, 2017 12:50 pm

Re: Recordings.xml issues

Post by Linux_lad » Sat Sep 29, 2018 8:52 pm

Hi Just had the same issue recordings file filled up with errors as second recording on an other channel failed.

Recordings file was 9 mb which failed to load into Vbox after restart, also had the old problem stating that you need to configure your box using the first time setup wizard. Edited the recordings file and removed 140405 lines of errors, all appears to be good again until the next time.

I thought all of these things were sorted now, Kids will be devastated in the morning due to lack of favorite program

Using latest firmware UK based DVB T/T2, also noted that after initial reboot second tuner not locked until I removed the errors from the file and did a re scan of the channels.

Any thought s from Vbox appreciated

Post Reply